Sony Vaio PRO 13 SVP132A1CW wont turn on, won’t power on, no display, black screen problems

Laptop Sony Vaio PRO 13 SVP132A1CW won’t turn on, won’t power on, there is no display, just a black screen. This is a general diagnostic and repair steps to fix those problems.

Troubleshooting laptop Sony Vaio PRO 13 SVP132A1CW won’t boot, won’t power on, no display just black screen

When you push on the Power Button the Power led lights ON or NOT, your Sony Vaio PRO 13 SVP132A1CW won’t start up, and there is no display just a black screen. Possible problem and the fixes steps:

Battery has no charge left + AC adapter failed; you press the power button on laptop Sony Vaio PRO 13 SVP132A1CW nothing happens, laptop won’t turns on and there is no display, the battery has no charge left, the motherboard doesn’t receive any power, laptop cannot turn on. You plug in the AC adapter but that doesn’t help, your laptop Sony Vaio PRO 13 SVP132A1CW still won’t power on, there is a chance you have failed AC adapter. In this case try with another charger or check AC adapter with a Multimeter. If it’s dead, replaced with a new one, (How to check AC adapter with Multimeter).

Power circuit in wrong state or Over volt protection trips; you press the power button but nothing happens, laptop Sony Vaio PRO 13 SVP132A1CW won’t turns on and there is no display just a black screen, your laptop has static electric charge made power circuit in wrong state. Unplug AC adapter, take out the battery and hold down power button for 30 seconds, the static charge will dissipate. Plug in the AC Adapter and turn on your laptop Sony Vaio PRO 13 SVP132A1CW. This should restore the system to normal operating mode.

Screen faulty or bad video cable connection; laptop Sony Vaio PRO 13 SVP132A1CW turns on, but screen is black, with Power led lights ON. Test the laptop with an external monitor connected to the HDMI port, VGA port or any Display port, press the appropriate key to switch to it. If the external monitor works fine and load the operation system, most likely you have a faulty screen or bad video cable connection. Check them and replace the faulty one.

Hardware failure; the laptop powers on, but there is no display just black screen with Power led lights ON or your laptop Sony Vaio PRO 13 SVP132A1CW stock on logo or restart. In this case, it’s possible one of the Hardware failed. You can try to disassemble the laptop to bare minimum and try to reseat the hardware one by one and power on the laptop every time you reseat a hardware to know the failed one, replace the faulty hardware,

Power button failed; the charge led lights on when you plug in the AC adapter, but laptop won’t turn on when you press the power button. Probably you have a Power button failure. The Sony Vaio PRO 13 SVP132A1CW Power button has to be repaired or replaced; you can short the power button borne with conductor wire to see if laptop turns on, (How to Test Power Button).

Some electronics components or chipset on the motherboard failed; Laptop Sony Vaio PRO 13 SVP132A1CW won’t turn on at all. Disassemble the laptop and take out the motherboard. With a Multimeter check electronics components continuity, Voltage and Chipset temperature, you will need an electronic Schematic Diagram for Laptop Sony Vaio PRO 13 SVP132A1CW. The failed electronic component has to be replaced, (How to test Laptop Power System). (Electronics components failure will be updated every time we fix this laptop)

BIOS failed; Laptop Sony Vaio PRO 13 SVP132A1CW won’t turn on at all, if the Power System and electronics components on the motherboard are good, there is chance you have failed BIOS, reprogram or replace the BIOS chip (How to reprogram (Flash). Laptop BIOS).

Motherboard dead; The Sony Vaio PRO 13 SVP132A1CW motherboard has to be replaced.

Download Sony Vaio PRO 13 SVP132A1CW BIOS bin rom file

For other Sony Vaio PRO 13 SVP132A1CW problems write a comment.

20 thoughts on “Sony Vaio PRO 13 SVP132A1CW wont turn on, won’t power on, no display, black screen problems

  1. zak

    So I purchased a defective Vaio Pro 13, which would not display anything on the screen, however the HDMI output works.
    I purchased a whole new screen assembly in the hopes that it would work, however still nothing. I took a flashlight and found that it was the backlight which was dead. I know how to solder, and have no problems with a multimeter, however I have never fixed a backlight fuse before, and I have no idea where the fuse is positioned. I took a picture of the display connector and the area around it, does anyone know where the fuse is? And could I just remove the fuse and solder between the pads to short it, to make it work?

    Image: http://imgur.com/RX3ViTE

  2. helppard Post author

    its a very small fuse , you got 2 near lvds but i dont believe are does ones . but one of them its green with a P on the right side of lvds , and the outher is like a little black resistor with the S letter on it . but my guess is that the fuse you look is on the outher side of the board .. best thing is to give us board code , for we can manage to tell you exact were to look

    Samsung NP535U4C wont turn on, won’t power on, no display

    the ones with a 0 insyde is 0ohm resistor it will act as a fuse also , so all does components i marked to you , must make continuity in continuity mode on your multimeter

  3. zak

    I actually tried testing continuity on the one with a S inside, and I’m pretty sure no continuity was detected,

  4. Ouiss

    Thank you guys for your post I’ve had the same problem with my sony vaio pro 13 when I changed my screen without disconnect battery, the same fuse burnt out and I just short this fuse and my favorite laptop is now safe thnaks from France

    Ouiss

  5. jose

    Esa misma averia tenia mi vaio. pero despues de desmontarlo y hacer mediciones…. algo hice mal y mi portatil ahora ademas de no tener imagen en pantalla tampoco me enciende. Mejor dicho, se enciende el led verde del power y a los 15 segundos se apaga. ¿Alguna idea de lo que he podido estropear?
    Gracias por vuestra ayuda y por las molestias de tener que traducir el texto.

  6. Jose

    That same problem I had until I removed the laptop to make some measurements and when reassembling it, now when turning on the laptop it turns on the green reads of the power is 15 seconds and flashes and turns off. Any idea that I could break down ?. Thanks for the help and for the effort in translating it.

  7. Jose

    I’ve already mounted it and it’s the same problem. 15 seconds them green and off and no screen image. Thank you.

  8. mag

    Hi,
    could you someone tell me, what is the element on the left on lvds (first black element with 3 pins) – is marked as WC3GV on the picture above?
    I have a problem with burnt of this element. Previously a resistor 0 Ohm was inserted instead of “S” fuse, so there was no security of circuit:-(. Thanks in advance.

  9. mag

    Thanks. Do you know what type/model of transistor it is? Maybe some datasheet/catalog do you have? I need to buy such the transistor for replacement, but I don’t know how to find them in the e-shops.

  10. Dominic

    Hi Josef Baroki – please can You help me with my problem ? I have 13 pro with “dead” motherboad – I had damaged display fuse ( laptop worked fine with HDMI ) but after unpluged display, motherboad was damaged – I tryed to run only motherboard with connected fan, temperature cooler sensor, display, battery and charger – first 2 hour after connected baterry or charger nothing – won´t start, nothing led light and nothing voltage on all fuses – after 2 hours started light LED of connected charger – after next hour when I start Laptop I get green power on led – but its all – no fan work, no usb power, no ssd / wifi power. I tryed reassembly around 5 times but nothing.
    If you help me to unbrick laptop, I will send you donate.

  11. Dominic

    Hi Josef baroki – can I contact you by other way ? First thanks for nice post about vaio 13 pro – my display fuse was too burnt but when I fixed that I unplugged display and plugged in my motherboard was damaged – first 2 hours nothing – no turn on, no charger light etc – after 2 hours I got charger light – after next 2 hour I get charger light and green turn on light – but its all – no cpu heat, no usb power 5v etc – I tryed laptop rebuild aboud 5 times, try unplug bios battery and try measure a few mosfets / fuses but I didn´t found any damage – can you help me with this problem or are you have schematic diagram for better measure and flash bios ( I didnt found bios chip)
    If notebook will work youre will get donate 😀


Leave a Reply

Your email address will not be published. Required fields are marked *

Type the numbers you see in the image below *